
P e d i T r e e
A Family History Program

Getting Started Guide

Version 3
by Colin Liebenrood

Pedigree Software
The Granary
Ryelands
Wyre Piddle
PERSHORE
WR10 2JG
England

Telephone: 01386 556 649



Contents

Chapter 1 Introduction 4
Concepts 4
About this Manual 5
 Getting Help 6

Chapter 2  Installation and Back-up 7
Installation 7
Database Elton55.ped 8
Technical Details 8
Back-up 9
Next Steps 10

Chapter 3  Tutorial 11

Starting,  Browsing,  Family Changes 11
A Starting and Stopping PediTree 11
B Open the Royal03 Database 12
C Moving around a family tree 14
D Finding a Person 15
E Zoom for more Detail 16
F Multiple Marriages 17
G Editing Information about People and Marriages 17
H Adding Children to a Marriage 18
J Adding Spouses 19
K Relating existing people — Mark and Place 20
L Detaching people 21
M Deleting  people and marriages 21
N Next Steps 22
O Restoring the Royal03 Database 22

Chapter 4  Tutorial 23

Printing Records and Lists 23
A  Start PediTree and Open Royal03 23
B Print an Individual Report 23
C Produce a Filtered List 25
D Print a Table from a List 26
E Export List as Text 27
F Delete Unwanted Lists 27



Chapter 5 Tutorial 29

Printing Trees and Charts 29
A Trees and Tree Plans 29
B  Starting PediTree for this Example 29
C  Creating and Using Plan A 29
D  Creating a Descendants Plan 30
E  Tall Tree 32
F  Ancestors Tree 32
G Wide Tree with Image 33
H  Lines of Descent 33
J Descendants Chart 34
K Ancestors Chart 35
L Delete Unwanted Lists 37

Chapter 6  Tutorial 38

Entering your own Family 38
A Create a new empty database 38
B Enter a Family 39
C Use Indexes 42
D Using Sources 43
E Census Records 45
F Database Checks 47
G New Database from GEDCOM File 48
H Back-up and Restore 50
J Other Matters 50

Chapter 7  Using your Database 51

Index 52

Acknowledgements
Microsoft, MSDOS and Windows are trademarks of Microsoft Corporation.  WinZip is
a trademark of Winzip Computing Inc.

Some of the material in this Guide is based upon the Pedigree User’s Guide by David
Hawgood.

This guide copyright © 2003–11 Colin Liebenrood and Pedigree Software.

Version 3  21 July 2007, revised 19 December 2007, April 2011



4

Chapter 1  Introduction

Chapter 1 Introduction
 PediTree is a database package designed specifically for genealogists and family his-

torians.  It is a development from Pedigree for DOS.  The facilities it provides can be
grouped into three main categories:

Data Entry: feeding information into PediTree from the keyboard or from another
file, for instance a GEDCOM file.

Data Analysis: finding out new facts about family relationships by giving PediTree
the task of analysing your research, by searching and sorting.

 Display: printing tables, charts and trees that show the results of your research.

Concepts
 A database is “a collection of related information”.   The contents of a card index is a

database; a family tree is also a database because it contains pieces of information
that are related, in this case by family links.  A family tree database may be extended
to include photographs and other related information, perhaps sound recordings.  It
can also contain associated source information from which the family tree has been
constructed, such as details of certificates, parish register entries and census returns.

Records and Fields
 A record is like a card in an index box — it contains various pieces of information

about something. For example, consider a society’s membership database. In the
past, it might have been a collection of cards, each of which contained information
about one individual, e.g. Name; Address; Date of Birth; Membership number and so
on.  These pieces of information are called attributes, or more usually,  fields.  Each
of these fields is of a particular type: the Name and Address are both text, whilst the
Membership number might be a number.

A Family History Database
 Family trees are complex collections of people and marriages.  Each person has two

parents and any number of marriages (or partnerships), each of which can result in
any number of children.

 As a database, PediTree has records with fields, but it has additional features de-
signed to handle family trees.  It has several different types of records; as a minimum
it has record-types for people and marriages, often for sources and census entries as
well.   People and marriages are linked together by the program, to construct the rela-
tionships of the family tree.  You don’t have to worry about this linking process  —
the program automatically keeps everything in order for you.

PediTree’s Databases
 One of PediTree’s features is that the design of the database can be altered to suit

particular applications.  Two different database designs are supplied with the pro-
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gram: one, called Royal03, is a simple design for use in a tutorial introduction that
follows shortly; the second, Elton55, is intended as the basis for your own databases.
As supplied, both contain some sample records, but PediTree can create new empty
databases for you to use, based on an existing design such as Elton55.  If you become
dissatisfied with this design, then it is possible for you to alter it, for example, by
adding additional fields to a record-type.  However, this is an advanced topic that
must wait until you are familiar with the package.

 PediTree is not restricted to working with a single database, but can comfortably
manage a number of them, although you can only use them one at a time.  So if you
are researching a number of unrelated families, you can easily keep their records sep-
arate.

 At the time of writing, the DOS program called Pedigree has to be used for some
purposes.  For this reason, it is convenient to keep the total number of databases to
twenty or less. Pedigree can handle the same database designs, but is limited to
twenty databases in total.

About this Manual
 This manual is to help you get started with using PediTree.  It is correct for version

3.316; other later versions may be different in some details, whilst earlier versions
may be quite different.  There is a second reference manual that provides more
detailed information about the program and its operation.

 After giving information about how to install PediTree and associated programs, this
manual contains two hands-on tutorials to introduce you to the program and the way
it works.  The first, in Chapters 3–5, uses an existing database.  The second shows
you how to create a new database and start adding details of a family into it, as you
will need to do for your own studies.

 It is assumed that you are familiar with operating programs in Windows, including
the use of the mouse to click, double-click and drag objects, the pull-down menus,
dialogues, on-line help and so on.  PediTree makes extensive use of the less-common
technique of pop-up menus produced by clicking the right-hand button. This will be
explained in the tutorial chapters that follow.

 To help you read these instructions, some typographic conventions are used through-
out to distinguish elements in the text:

List Dialogue    Names of windows; menu choices, etc.

forenames like "Elizabeth" Things you type.

 The common operation of working through cascading menus in Windows is depicted
as, for example, Start > Programs > Pedigree > PediTree.
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Getting Help
 As is usual with a Windows program, comprehensive on-line help is available:

  From the main Help menu

  By clicking on Help buttons in some places

  By pressing the F1 key

  In the Edit display, by right-clicking on a field name.

 The last three produce help relevant to the context in which they are used.  The on-
line help has the usual Contents list and Index to assist you to find information about
matter of interest.  The on-line help is likely to be more up-to-date than the printed
manuals.

 Pop-up hints appear as the mouse pointer is moved over the various display ele-
ments.

Contacting Pedigree Software
 If you are unable to find the answer to a question from the manuals or on-line help,

or if you encounter a fault in the program, then please contact the author and suppli-
er, Murray Kennedy. Have available details of the version of the program (from
Help > Version); the database version (from Options > Definition) and the version of
Windows you are using.

 Email:  MurrayKennedy@btinternet.com

 Telephone: 01386 556649

 Fax:  (none)

 Post: Pedigree Software,  The Granary,  Ryelands,  Wyre Piddle,
 PERSHORE,  WR10 2JG,  UK

Pedigree Software’s web-site provides news of latest versions and upgrades:

 http://ourworld.compuserve.com/homepages/pedigreesoftware

Pedigree Users Group
 This flourishing users’ group provides a quarterly newsletter, an e-mail discussion

list and has many members who are pleased to help users in their locality. More
information is available from their web-site <www.pugweb.org.uk>, or the Member-
ship Secretary, 19 Lombardy Close, Leverstock Green, Hemel Hempstead,
HP2 4NG, England, email <membership@pugweb.org.uk>.
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Chapter 2  Installation and Back-up
Installation
 Pedigree Software now supply their programs on a single CD-ROM.  These pro-

grams are:

  PediTree (The subject of this manual)

  Pedigree Utilities (GedUtils; PedSpecs; Printing for Pedigree.)

  Pedigree 2.6N (for DOS, needed for some operations)

 PediTree and Pedigree Utilities require Windows 95 or later, including Windows
NT,  XP and Vista.  Pedigree requires MSDOS 3.3 or later; the installer on the CD
requires Windows 3.1 or later.

 The CD-ROM includes an interactive
installation routine that uses your Web
Browser. This should start automati-
cally when you insert the CD in the
drive.  If not, try double-clicking the
drive icon in My Computer, or click on
Start, choose Run, type
d:\Pedigree.htm and press the
Enter key (where d: is the drive letter
for your CD drive).

 The interactive installation routine dis-
plays further information about each
program that you can read before
clicking where indicated to launch the
installation process. In each case, the program installer will present you with some
choices to confirm before actually installing the program(s).  Unless you have your
own reasons to change it, you can simply accept the default choice at each step and
let the installer do its work.  PediTree and Pedigree are installed in folder
C:\Pedigree, with their databases in sub-folders; Pedigree Utilities are installed in
folder “C:\Program Files\Pedigree Utilities”. On completion, you will be able to start
any of the installed programs from entries in your Start menu, under
Programs > Pedigree.

Note:  for Win3.1 users, only Pedigree can be installed and it will be accessible
from the Pedigree program group.

 If you prefer to install the individual programs yourself (or the interactive installation
fails), then the program names to use in the Start > Run command are:-
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  PediTree  d:\setupPT
  Pedigree Utilities  d:\setupPU2
  Pedigree   d:\install
 where d: is the drive letter for the CD drive, as before.

 The installation of PediTree includes several utility programs. GZip is supplied for
expanding upgrades to PediTree, which are supplied by e-mail in compressed form.
Ped-FHS can be used to convert GEDCOM version 4 files from PediTree into for-
mats acceptable to other Family History programs. PVsort is a general-purpose sort-
ing program used by PediTree that can be used for other purposes.  Documentation
files for GZip and PVsort are included.

Database Elton55.ped
 The CD-ROM also includes a separate copy of the standard database design

elton55.ped. Although this is installed with PediTree (or PediView), you may alter
it when trying some published tutorials and then wish to restore the original version.
To do this, use Windows Explorer to copy the elton55.ped folder from the CD to
your hard disk to replace the working copy.  You will then need to use Explorer to
remove the read-only attribute from the files in the folder.

Removing the Read-only Attribute
1 Navigate into the elton55.ped folder on your hard disk.

2 Select all the files, by pressing keys
Ctrl+A or otherwise.

3 Right-click on the selected files and
choose Properties.

4 Clear the read-only box, by clicking on
it.

5 Click on OK.

Note:  this same operation will be
needed any time you copy a
Pedigree database from a CD-
ROM, perhaps to restore a
back-up copy.  Any file copied from a CD will normally have the read-only
attribute, which must be removed before it is used.

Technical Details
 If you use Windows Explorer to examine the files you have installed in the Pedigree

folder, you will see that there are two sub-folders: Royal03.ped and Elton55.ped.  The
reason is that PediTree stores each database in a separate folder; each of these folders
contains one database.  Creating another database will create another folder with a
new name.
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 The illustration shows the Windows Explorer view of the Royal03.ped folder. In this,
the Person.* files hold person informa-
tion; Marriage.* files hold the marriage
information.  The file lists.dat holds in-
dexes, lists and tree plans; these terms
will be explained in the tutorial that
follows. The file control.ged contains
the database design, which includes the
records, their fields and definitions of
how the stored information is to be dis-
played and printed.  Each additional
record-type adds three files, so data-
base Elton55.ped will be found to have
fourteen files in its folder.

 Most PediTree database folder names  end with the filetype ‘.ped’. A database with
this folder type can hold a maximum of 1 megabyte of information in each record-
type: Person, Marriage, etc.  When necessary, other types can be created that will
hold more information. The folder filetypes and the maximum capacity of each are as
follows:

  Filetype  Capacity Pedigree compatible

  .ped  1Mb   yes
  .pdg  3Mb   yes
  .pdh  4Mb   yes
  .pdj  6Mb   no
  .pdm  9Mb   no

 PediTree stores information very efficiently, so most family trees will fit into the ba-
sic 1Mb type.  If this turns out to be inadequate, then it is easy to convert to a larger-
capacity type when needed. Note that the two rarely-needed largest types are not
compatible with Pedigree for DOS, which cannot handle them.

Back-up
 As you may be using PediTree to store a lot of hard-won information, it is important

that you make regular back-up copies to guard against inadvertent loss in case of ma-
chine or program failure, human error or other accident.  Regular back-up copies on-
to several sets of removable media, kept separate from the computer, are a vital
defence against such frustrating and time-consuming loss.

 To make a back-up copy of a PediTree database, the whole contents of its folder
must be copied.   Many family databases are of a size that will fit onto a single high-
density (1.44Mb) floppy disk. Computers are now usually fitted with drives of much
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greater capacity that will hold a number of the largest PediTree databases, such as
writable CDs or ZIP disks.

Note:  always close PediTree before making a back-up copy. If PediTree still has
your database open, the back-up copy you make may be incomplete or
inconsistent. You will only discover this when and if you have to restore
your database from the back-up copy.

 To make a back-up copy, use appropriate Windows techniques to copy the database
folder(s) to a suitable medium.  For floppy disk or ZIP disk, the technique known as
‘drag and drop’ may be used in Windows Explorer.  For a writable CD, use the relat-
ed burning program.  If you need to use floppy disks to hold the back-up of a data-
base that is too large for one floppy, then suitable compression programs are
available that both reduce the size of the folder and can spread it across several flop-
pies if necessary.  One such program is called WinZip; there are several others.
Please see the relevant Windows and other documentation for further details.

Note:  when using drag and drop to copy a PediTree database to another location
on the same disk, remember that you must press and hold the Ctrl key to
make the operation ‘Copy’ instead of ‘Move’.

Next Steps
 Now try the tutorial in the next three chapters, which will introduce you to the facili-

ties and operation of PediTree.
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Chapter 3  Tutorial
Starting,  Browsing,  Family Changes
 This Tutorial is intended to introduce a new user to the basic operation of the

PediTree program.  No prior knowledge is expected, except some familiarity with the
operation of programs in the Windows environment. These instructions assume that
you have already installed PediTree from Pedigree Software’s installation disks and
so have an entry for the program in your Start menu.

A Starting and Stopping PediTree
1 Click on the Start button, choose Programs > Pedigree > PediTree. The program will

launch and display its opening screen. At the top is a standard Windows menu bar,
showing File, Edit, List.... Help. Next
down is a so-called speed-bar with but-
tons for commonly-used functions;
most of these are blank until a database
is open. Below this is a panel showing
your Pedigree serial number, a copy-
right notice and your name and
address.  The top bar of this panel
shows details of the PediTree version
that are important if you should
encounter any problems.

Note:  for full use of PediTree, your se-
rial number should be greater than 3200 or have the suffix ‘w’.  You will be
able to complete this tutorial if your number is not like this, but will need an
upgrade from Pedigree Software if you wish to use PediTree to the full.

2 PediTree is supplied with some sample databases:-

Elton55 a basis for your own databases

Royal03  about 150 members of the British Royal Family, for use with this
tutorial.

 If you have previously used Pedigree for DOS, then you may have some additional
databases.

 We will be using Royal03.  There are a small number of important people and links
missing from this database, also some interlopers and erroneous liaisons.  Your task
will be to add these missing people and links and to remove the errors. A back-up
copy of this database is supplied, in case you want to start this tutorial again with a
clean slate.  See section O for details.
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3 To stop using PediTree, pull down the File menu, by clicking on it or by pressing the
Alt key with the letter F (usually written as Alt+F), then choose Exit.  (We will in
future use the shorthand File > Exit for such operations.

 There are several other ways to achieve the same result, many of which are common
to all Windows programs. You can click on the open-door button at the right of the
speed-bar; click on the close program box at the extreme right of the title bar; press
the key combination Alt+F4.

4 The first time you use PediTree after installation, there is one setting you should
check, namely, the font used for the
family display.  Choose Print > Fonts
from the menu bar, which should pro-
duce a dialogue looking like this illus-
tration.  On first use, the last font listed
is often System instead of Terminal.
Double-click on this font to get a
standard Font dialogue, which will
show Terminal as the selected font.
Click OK to choose it; click OK again
to clear PediTree’s fonts list dialogue.
On subsequent uses of PediTree, this
setting will be correct.

B Open the Royal03 Database
 To tell PediTree we want to work on the Royal03 database, we need first to open it.

1 From the main menu, choose File > Open.  Or click on the Open button in the speed-
bar, just below File.  An Open Data-
base dialogue will appear, listing the
databases that are available.  Most
PediTree databases end with ‘.ped’;
you may also see ‘.pdg’, ‘.pdh’, ‘.pdj’
and others.  You should see royal03.ped
in the list.

 If you are coming back to this tutorial,
then you will see royal03.ped listed
near the bottom of the File menu,
where a list of recently-used databases
appears.  You can choose this entry to open it, instead of using Open... and the fol-
lowing step.

2 Move the highlight onto royal03.ped by clicking it with the mouse, or by using the
arrow keys.  Then double-click it (or press the Enter key).  After a moment, you will
see PediTree’s family display, showing Queen Elizabeth, Prince Philip, their parents
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and their children.  On the left is a list of people in the database, in order of their
forenames.

 The PediTree window is headed ‘PediTree c:\Pedigree\Royal03.ped+0’. This shows
which database is in use (or open); the ‘+0’ indicates that it has not been changed
since it was created.

 All the buttons in the speed-bar are now visible.  Two change their appearance to
reflect their status.  You can hold the mouse pointer over each one in turn to see a
description. We shall be seeing how they are used later in this tutorial.  The illustra-
tion at the top of the next page shows them in detail.

 The family display is headed ‘Family of ^M029 Philip ^P060 & Elizabeth II ^P067’.
The M... and P... numbers are PediTree’s internal reference numbers (called Record
Identity Numbers — RINs for short) to the marriage and the persons respectively.
The preceding caret ‘^’ marks them for use as hot-links for moving around the fami-
lies, as we shall see later.  This display is active, as shown by the colour of its title-
bar.

 The leftmost area of this display shows the children of the marriage. These are
shown in the order in which they are entered — PediTree doesn’t assume they will
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be ordered by date of birth.  Up to 20 children may be entered. A person marked with
3to the left of their name has children; the number is shown as, e.g. +2 on the right.
A person marked on the left with = has a marriage, but no children recorded here.

 The central area shows the couple named in the display heading — parents of the
children on the left — with details of their marriage between them. To the right of
this couple are both their parents (the children’s grandparents), if present in the data-
base. If these in turn have parents in the database, then they have4to the right of
their name.

3 The bottom half of the family display is a Detail Box.  It initially contains a message;
click on any person in the family display to see more details about them in this space.
The person so selected will change colour to white, or for a child, be marked by a
selection rectangle (dotted).

4 On the left in the main window is a list display, headed ‘List1 Indexed with 150 Per-
son Records’.  This list display is inactive, shown again by the colour of its title-bar.
It  shows a list of people sorted into alphabetical order — this is an index that will be
used later.  The title of this list display changes as you use PediTree — you can have
an index, various lists or plans.  The difference is that an index keeps up-to-date as
you make changes, whilst lists or plans do not; they must be re-created to update
them after changes have been made to the database.

 The list display has its own Detail Box.  Clicking on a list entry will a) make the list
display active; b) show details of the selected person in the Detail Box.

C Moving around a family tree
 You can use the family display to browse around a family tree; moving up and down

between generations or sideways through multiple marriages. This is done with the
mouse: a click selects the person and displays information about them in the Detail
Box; a double-click brings that person to the central position in the family display.
To try this, go through the numbered steps following:

1 Click on the Queen Mother; her details will appear in the Detail Box.

Open
Database

Choose
List

Toggle View /
Edit (Update)

Plan Descendant
Tree

Ancestors
Chart

Show Family of
Current Person

Plan Ancestor
Tree

Set Printer
Orientation

Descendants
Chart

Find Current
in Index
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2 Click on the Queen; her details will replace those of the Queen Mother.

3 Now double-click on Charles; his marriage will move to the central position, with his
children shown (one only; we shall add Prince Harry shortly).

4 Notice a pair of arrows have appeared
top centre of this window; these allow
you to move the family display back-
ward to previous positions (up to
eight).  Click on the downward arrow
to return the Queen and Philip to the
central position.

5 You can use the RINs in the Detail Box
to navigate around the family.  Click on
the Queen to make her details appear in
the Detail Box. Now position the I-cur-
sor just to the left of ^P062 (after
George VI), press the left button, move the cursor to the right over the number and
then release the left button.  The Detail Box will change to display George VI’s
details and the highlight will move to him in the family display. PediTree calls num-
bers preceded by the caret ^ hot links.   The process of selecting them with the mouse
described above is called swiping.

 Now do the same for his mother, Mary, by swiping ^P019 to move to her family. We
are now off the family display (which doesn’t change), so no person is highlighted.

D Finding a Person
 There are two ways in PediTree to go directly to a particular person or marriage.

 1. By using the RIN, if you know it.

 2. By name, through an index of people or marriages.

1 Select RIN:  the first method is the quickest, but you must know the RIN. Move the
cursor onto the father in the family dis-
play (Philip), then click the right mouse
button.  From the pop-up menu, choose
RIN select..., then type 112 in the box
marked Enter PIN and press the Enter
key. The family display is set to that for
Henry VIII, who is person 112. The
details of his first marriage are shown.

 Now right-click on the marriage box
(between the parents), choose RIN
select... and enter 42 to see Henry’s sec-
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ond marriage.  There are other ways to move between marriages that we’ll explore in
section F.

Find in Index: an index is a list ordered in a particular way, for example alphabetical
order of surnames and forenames.  The Royal03 database has an index of forenames
in alphabetical order; most members of the royal family do not use ordinary sur-
names.

2 Right click in the list display and choose Find Person..., then type henry viii in the
Find forenames box.  As you type, the list highlight will move to matching entries
(Haakon; Helena; Henry...), so you can stop typing when you get to the wanted
entry, then press Enter to select it.  Or you can stop nearby, press Enter, then use the
arrow keys to get to the desired place.

3 To get a family display for the selected list entry, you can click the Show Family but-
ton on the speed-bar, or choose Edit > Family from the main menu.  This opens a new
family display on the selected person.

4 If you want simply to reset the original family display, note the RIN of the selected
person, then use the method in D1 above.

E Zoom for more Detail
 With Henry VIII selected, there is too much information to display all of it in the

Detail Box, at the bottom of either the list display or the family display. We can
expand it when required.

1 Click once in the Detail Box and it will expand to show all the information.

2 We tried earlier swiping hot links in the Detail Box to display the details of different
people.  This technique also works for  references to other files, such as images. At
the bottom of the expanded Detail Box is the line

   Objects:\pedigree\HenryVIII.jpg

 Swipe this, moving right from before the first backslash, that is, just
\pedigree\HenryVIII.jpg.  Up will pop an image of the King.  Click on its Close box to
remove it.

3 Finally, click again in the Detail Box to return it to normal size.

Note:  if your PediTree installation is in a different folder from the default  \Pedi-
gree then step 2 won’t work.  You will need to edit Henry’s record to alter
the file reference to suit.  We shall be editing some records in section G
below.
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F Multiple Marriages
 If father or mother in the family display married more than once, then this is indi-

cated by tabs in the marriage window.

 This display shows Henry VIII’s five marriages and Catherine of Aragon’s two.
(Surely Henry married six times?  Yes, you’ll be adding the missing wife later.)

1 Click tab 2  under Henry to see his marriage to Anne Boleyn. Click tab 1 to return to
Catherine of Aragon.  Click her tab 1 to see her first marriage to Henry’s brother.

G Editing Information about People and Marriages
 To make any changes to records of individuals or marriages, you must first be in Edit

(Update) mode. Up to now, you have been in View mode, in which you cannot make
such changes.

1 To change to Edit (Update) mode, choose Edit > Update (Edit) from the main menu, or
click the View/Edit button underneath.  You will see that this button changes to
reflect the current setting.

2 Find Charles P088 in the family dis-
play (see D1 above to remind yourself
how). Right-click and choose Edit P88.
The edit display will appear, with a
vertical display of Charles’s details in
labelled fields. Some groups of fields,
like birth, are shown in collapsed
form, indicated by a + in the left mar-
gin.

3 You can move the selection rectangle
with the arrow-keys or by clicking on
a chosen field with the mouse.  We
will enter Charles’s birth details, so
move to the birth group and expand it:
either press the Enter key or click on
the + sign. The birth group will
expand to show its constituent fields,
as shown in the illustration.

4 The birth date field is selected, so type 14nov1948.  Move down to the place field
and type Buckingham Palace. If you move up to the birth line and press the Enter
key, or click on the - sign, then the birth group will be collapsed, showing the new
details in summary form.

5 Press key F9 (or right-click in the Field column and choose Save Ctrl+S or F9) to close
the edit display and update Charles’s record on disk and in the other displays. (To
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abandon your changes, click the close button at the top right of the edit display, or
press the Esc key, then click No in the ensuing dialogue.)  Click on Charles in the
family display to update the Detail Box with the new information. Notice that at the
end of the text it says “Changed:”, followed by the date and time.  PediTree automat-
ically updates a group of fields in the record, called changed, whenever a record is
edited.

 To change details of a marriage, right-click on the marriage details between the par-
ents and choose Edit.  Let us enter Princess Anne’s divorce.

6 Find Anne P089 in the family display and double-click to bring her and Mark Phil-
lips to the central position.  Now right-click on their marriage, choose Edit M51 and
an edit display with their marriage details will appear. Expand the the divorce group
to show the component fields, and type 1992 in the divorce date field.  Now press
key F9 to close the edit display; the marriage will now show the divorce.  We shall
add her 2nd  marriage shortly.

H Adding Children to a Marriage
 People are added to the database in a similar manner to editing existing records.  This

section explains two ways to add a child to an existing marriage.

1 Add child: if the child you want to add is the youngest so far, then in Edit mode
there is an empty space at the bottom of the list of children into which the child will
go.  (If you have just switched to Edit mode from View mode, then this space will
only appear when you reposition the family display.)  Move back to Charles &
Diana’s family, by clicking the up-down arrows (or by double-click on one of
Anne’s parents, then double-click on Charles).  There is an empty space below Wil-
liam: right-click and choose Edit new person.  An edit display appears: enter Prince
Harry’s details:-

  sex m

  forenames Harry

  prefix Prince

  birth date 15sep1984

 Press key F9 twice, as before, to close the edit display and save the new information;
you will see that Harry has appeared as the second child.

2 Insert child: in a similar manner, you can insert a child who is not the youngest.  Try
this with the Queen’s son, Andrew, who is missing: first reposition the family dis-
play with the Queen and Prince Philip at the centre.  Now right-click on Edward,
who is younger than Andrew, and choose Insert child.  A space will open up between
Anne and Edward to accommodate Andrew; right-click on this space, choose Edit
new person and enter Prince Andrew, born 19 Feb 1960.
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 If you make a mistake and get the child in the wrong position, you can always cor-
rect it.  Furthermore, if two children are in the wrong order and both have birth dates,
PediTree will indicate this.  We will interchange Anne and Andrew to illustrate this.

3 Depress the left mouse-button on the child number to the left of Andrew (3),  hold
the button and drag it up so that the dark position-line is above Anne.  Release the
mouse-button, then click on OK to confirm the repositioning.  You will see that
Andrew is now number 2, Anne number 3; the 3 carries a question mark to indicate
that the birth-dates are in the wrong order.  Drag Andrew down to below Anne and
confirm the repositioning to restore the correct order.

 If you insert a child in the wrong family, then you can either move it elsewhere or
delete it entirely, as will be explained in Sections K, L and M below.

J Adding Spouses
1 To add a spouse, simply make sure that the existing spouse is in the centre of the

family display, position the mouse-pointer on the empty spouse, right-click and
choose Edit new person. Enter the spouse’s details in the resulting edit display.  Try
doing this with Andrew, adding Sarah Ferguson, born 15 Oct 1959.  When adding a
spouse, PediTree automatically enters the correct sex, so you don’t have to do so.

 In adding the spouse, a marriage record is created automatically.  You can edit this
(by right-clicking on it): enter Andrew & Sarah’s marriage date (23 July 1986) and
divorce (30 May 1996).

2 Adding a second marriage: to add a second (or subsequent marriage), bring the
existing marriage to the centre of the family display.  Right-click on the spouse who
is to remarry and choose Add marriage.  Then right-click on the blank spouse, choose
Edit new person and insert their details.  Finally, right-click on the marriage to insert
the date, etc.  Try this with Anne, to add her 2nd marriage 12 December 1992 to Tim
Laurence, born 1 Mar 1955.

 Tabs for the 1st and 2nd marriage now show under Anne’s name in the family dis-
play.  You can click on either one to see the relevant marriage details; the current tab
is dark, the others light.

3 Inserting a marriage: in exactly the same way as you can insert children, you can
insert marriages.  You can try this on the best example of multiple marriages — King
Henry VIII.  Right-click on the father position in the family display, choose RIN
Select..., type in 112 and press Enter.  As before, you will see only five marriages;
select the 4th (to Catherine Howard) by clicking on that tab. That’s wrong — his 4th
wife was Anne of Cleves.  Right-click on Henry, choose Insert marriage. He now has
six marriages.  Right-click on the blank spouse, choose Edit new person and insert
details of Anne of Cleves (1515–1557); the ‘of Cleves’ goes in the postfix field.  Edit
the marriage to add the date (1540).  If you now click on Henry’s 5th marriage, you
will see that this is now, correctly, to Catherine Howard.
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K Relating existing people — Mark and Place
 Sometimes you may want to relate people who are already in the database.  For

example, you may discover that someone is a cousin of their spouse; this has hap-
pened often in the royal family.  In PediTree, it is never necessary to duplicate infor-
mation.  Relationships between existing people are added in a similar way to adding
new people, the only difference being that no new record is created.  The two basic
functions needed for this are Mark and Place.

Place a person as a child of his parents: to try this, we will relate the Queen to
Prince Philip—they are third cousins, with common great-great grandparents Queen
Victoria and Prince Albert.  The line from Victoria to Philip is broken in two places;
to start with we can link him to his parents, by placing him into his family.

1 First, find Prince Philip (P60), right-click on him and choose Mark P60.  The legend
P60=Philip ^P060 appears in the centre of the speed-bar.  Next we must find his par-
ents and bring them to the centre of the family display.  To make it easy, use the RIN
of their marriage: 18 (remember how? — see D1).  You will see that Andrew of
Greece and Princess Alice have no children.  Now right-click in the empty child
position,  choose Place P60=Philip ^P060 and  then confirm your choice.  Prince
Philip appears as the 1st child of the marriage.  Now double-click on Philip to bring
him and Queen Elizabeth to the centre of the family display; Philip’s parents are now
showing, as are his four children.  You have added a new relationship.

2 Relating people by marriage: you might discover that cousins are married. To con-
tinue our example in this database, there are two people who should be married: Lud-
wig VI, Grand Duke of Hesse (P24) and Alice (P5), a daughter of Queen Victoria.
First find Ludwig in the list display by RIN select (24) and mark him.  Next bring
Alice to the centre of the family display, again by her RIN (5).  Now right-click on
her blank husband, choose Place... and confirm that you want to join them. Ludwig
will appear, together with his parents.

 Prince Philip is descended from Ludwig and Alice via Princess Victoria of Hesse.  In
the list display, select Princess Victoria (RIN 25) and mark her.  Now place her in the
family display as a child of Ludwig and Alice.  If you now move down Victoria’s
line (Victoria > Alice > Philip) you will reach Prince Philip and Queen Elizabeth.

3 Checking Relationships: one way to check that they are cousins is to use PediTree’s
Relationship calculator.  First mark Prince Philip; next click on Queen Elizabeth;
then choose List > Relationship... from the pull-down menus and confirm that you wish
to calculate their relationship.  They are both four generations from Queen Victoria,
so are indeed third cousins, as stated at the outset. Over the page is a section of the
display showing this.
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L Detaching people
 The facility to detach people is the

reverse of the above; it is needed if a
mistake is made by relating people who
aren’t related.  For example, suppose
you put someone as the child of the
wrong parents.  To disconnect them
from this marriage, you detach them.
This does not erase their record — they
still exist in the database, but without
parents.

Detach a child from parents: make
sure the child’s parents are in the centre
of the family display, so the child is
amongst the children on their left.  Then right-click, choose Detach child and con-
firm.

1 Let us try this, by removing a child.  To show that the record still exists, we will then
immediately put him back again!  Bring George I (P97) to the centre of the family
display, then click on his second child; how did he get in here?!  Before detaching
him, right-click on this second child and mark him, as in K1 above.  Now right-click
again, choose Detach child 2 and confirm the operation.  George I now has only one
child: George II.  Note that the speed-bar still shows the alien; right-click the 2nd
child position and place him back in the family. This demonstrates that his record has
not been removed.  We’ll look at another way of removing this alien later.

2 Detach a spouse: you may have ‘married’ someone to the wrong spouse.  There is
an example in this database — Elizabeth I is shown, incorrectly, as married to Sir
Walter Raleigh, her favoured admirer.  First bring Elizabeth I (P121) to the centre of
the family display.  Now right-click on Sir Walter, choose Detach husband and con-
firm your choice.

 The marriage record still exists, but with only one spouse — Elizabeth.  This is per-
fectly acceptable in PediTree, as often you may only know about a husband or a
wife, not both.  If you eventually identify their correct partner, then you can add
them in, or mark and place them, as we have seen earlier.  However, in this case, you
want to delete the marriage.  This is described next.

M Deleting  people and marriages
 Sometimes you may enter a record accidentally, or add someone twice.  On these

occasions, you must delete the person or marriage that you accidentally added.

1 Delete person: let us revisit George I’s alien son, who has no business here!  Bring
George I (P97) to the centre of the family display, then again click on his second
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child.  This time, right-click, choose delete P148 and confirm the deletion.  Note that
well as removing any relationships that the person may have had, their record is per-
manently deleted — you cannot restore it except by retyping.

2 Delete marriage: similarly, you can delete a marriage.  This will detach any
spouse(s) and children, leaving their records otherwise intact.  Try deleting Queen
Elizabeth’s false marriage: bring her (P121) to the family display, right-click on the
marriage, choose Delete M60 and confirm the deletion.

N Next Steps
 This ends the first part of this tutorial.  We shall not be making any more changes to

the records, so click on the View/Edit (Update) button to switch back to View mode.
You may want to take a break now, before going on to study Lists and Printing.  If
so, you can leave PediTree, as described in section A3.

O Restoring the Royal03 Database
 If you want to re-run this section of the tutorial from the beginning, you will need to

undo all the changes you have made,  so as to start again with a clean slate.  A back-
up copy of the database is supplied for this purpose.  By restoring the database from
this copy, it is returned to its original state.

 This must be done with the database
closed, thus outside PediTree.  Use
Windows Explorer to find the file
Royal03.exe in your PediTree folder
(not the database folder Royal03.ped).
Double-click on this file to obtain a
display like this. Click on UnZip to
restore the Royal03 database to its orig-
inal state.
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Chapter 4  Tutorial
Printing Records and Lists
 In this section we will print Tables and Reports for members of the Royal Family.  It

doesn’t matter whether you have made the changes to the database as described in
the previous chapter, although it may make some difference to the exact results you
get.

A  Start PediTree and Open Royal03
 You can continue from the previous chapter if you wish.  If you have had a break,

then start PediTree again and open the Royal03 database.  See Chapter 3, sections A
and B if you need to be reminded how to do this.

B Print an Individual Report
 In PediTree, a Report is a fixed-layout display. Three are provided, called Individual,

Pedigree and PersonPhoto. We will print one of each.  Here is the top of the first:
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1  Right-click on George VI in the family display (if he isn't showing, then you can use
first use RIN Select to get him there; his RIN is 62).  Choose draw Report... : a blank
window with three tabs at the top will replace the family window.  Click on the tab
marked Individual and you will see the top part of a Report about George VI  (see
previous page). Now right-click and choose Print 1 to get a printer dialogue. This will
show your current default Windows printer, to allow you to change it or its settings if
you wish.  When ready, click OK to get a printing dialogue  that shows the Report
title and heading, which you can alter
if desired.  When satisfied, click on OK
and the Report will be printed.

 To return to the family display, you
would click on the tab marked Back.

2  Instead, click on the tab marked Pedigree.  You will see the left-hand end of a pedi-
gree for George VI, but be unable to scroll to see the right-hand part of it.  This
Report is designed for paper in the landscape orientation; we are currently set for
portrait.  From the main menu, choose Print > Setup Paper (or click on the Set Printer
speed-button) to get a Print Setup dialogue, choose Landscape orientation and click
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OK. (Note that the Set Printer speed-button has changed shape to landscape.)  Back
in the Report window, click the Individual tab, then back to the Pedigree tab (to
refresh the display).  You can now scroll to the right-hand end of the Report.

 Now right-click, choose Print Page 1 and follow the same sequence as before to print
this Report. Finally, click on the Back tab to return to the family display.

 3 For the last Report, reposition the family display to Henry VIII (RIN 112).  This is
another Report designed for Portrait orientation, so use the Set Printer speed-button
and reset to Portrait. Now right-click on Henry VIII and choose Draw Report, then
click on the PersonPhoto tab.  If you use the scroll-bars to move down to the bottom
of the report page, you will see a picture of the King.

 Finally click on the Back tab to return to the family display.

Note:  PediTree doesn't yet provide a way to design new Reports or alter those
provided. (This can only be done with Pedigree for DOS.)

C Produce a Filtered List
 You can follow a similar procedure to print Reports from a List window. A right-

click in a list will allow you to choose draw Report... and open up the same choices as
in the previous section.  If, when you right-click on the chosen Report layout, you
choose Print all..., you can confirm that you want to print the Report for all entries in
the list.  However, at one page an entry, you will probably choose to click on Cancel!

 There are two alternatives: one is to filter the list to reduce the number of entries, the
other is to use a Table.  Tables provide a more compact layout for multiple entries.
We will use both of these techniques: first, we will filter the list, then print a Table
from the result.

1  If you have followed through this tutorial as written, then you will have list 1 dis-
played, with the heading List1 Indexed with 154 Person records; the exact number will
depend upon whether you have completed the whole of Chapter 3.

 If another heading shows, then you
will need to get back to list 1. Click on
the Choose List button on the speed-
bar (or choose List > Choose... from the
main menu) to get the List Dialogue,
then click anywhere on the first line to
get List 1 displayed.

2  We will now select some entries from
this list by filtering it. Right-click on
any entry in the list and choose Filtered
search... to get an empty script window and a message saying ‘Please enter your fil-
ter’.  Click OK to remove the message, then type forenames like "Elizabeth"
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into the window.  In this expression, forenames is the name of a field; an alternative
to typing it is to click on the Fields button and select it from the resulting list. The
word like acts to select records where the contents of the forenames field sounds
alike the word that follows (using the Soundex system). In this case, it will select
Elisabeth as well as Elizabeth. You can select like "   from a list produced by
clicking on the Conditions button. Finally, the quotation marks are required in
"Elizabeth", but it does not matter whether the word has any capital letters.

 Now click the Test button and see the message ‘script OK but no output for this
record’, then click OK.  (If, by chance, your original right-click was on an Elizabeth,
then the message would be simply a RIN, e.g. ‘0102’; any other message probably
means you have mistyped). You will see a new list of seven records, all of which
have the expected forename.

 There are other possible expressions that could have been used. If you used fore-

names = "Elizabeth" the list would have omitted Elisabeth, Elizabeth I and Eliz-
abeth II (the last two because of the presence of I or II). The expression forenames

contains "Elizabeth" would find all except Elisabeth.

 Now this list exists, it will remain in being.  Section F of this chapter show how to
erase the list when you have finished with it.  However, if you were to add another
Elizabeth to the database, it wouldn’t appear in this list.  Of all the possible list types,
only indexes are updated when records are added, changed or deleted; all the other
types are unchanged.  To bring a filtered list like this one up to date, it must be
erased and re-created.

D Print a Table from a List
1  Right-click on any entry in the new list and choose drawTable. A blank window with

five tabs at the top appears. Click on the tab Simple to see the seven records in a sim-
ple tabular layout.  Right-click to choose Print page 1 and proceed as before to get a
printed copy.  Finally, click on the Back tab to return to the list.

2  You can further filter the list if you wish, for example, to select only those who have
a surname.  As before, right-click on any entry in the list and choose Filtered search...,
click OK to the message and type the script surname present. Click on the Test
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button if you wish, or simply click OK.
The new list window will show just
two records.

 Now right-click on one of these entries
and choose drawTable.  You might like
to try the Detailed table, by clicking on
that tab, or you can try each tab in turn
to see if you would prefer another sort
of Table for these records.  Make your choice and print it as before; the Back tab will
take you back to the list.

E Export List as Text
 You can export Tables to a file for use by other programs.  The export can be as an

image or as text. For text, you can choose from tab-delimited or CSV (Comma-sepa-
rated Values.  The former is best if you want to use the Table in a word-processed
document; the latter for import into a spread-sheet.  We will export the Simple Table
in tab-delimited form.

1 First, find the list 3 with seven entries, which is probably visible behind the most
recent list 4.  If so, click on its title-bar to make it active.  Now right-click and
choose drawTable as before.

2 Click on the Simple tab to see the Table. Right-click and choose Save Image or Text >
Save Tab delimited.  A standard File Save dialogue will appear.  Navigate to a con-
venient folder for the next step, give a suitable filename and click on Save.

3 Now start your Word Processor (you don’t need to leave PediTree first) and open the
file you have just saved.  With a suitable font-size and tab-settings, you should be
able to obtain a display much like the Table in PediTree.  (I can’t tell you exactly
how, as I don’t know what word processor you use.)

4 Return to PediTree.  As before, the Back tab will return you to the list display.

F Delete Unwanted Lists
 In sections C and D, we generated two new lists, one of seven Elizabeths, the other

of the two Elizabeths who have surnames entered.  We are unlikely to want these
lists again, so can delete them.  You can have up to twenty lists, which PediTree
saves when you leave the program, so they can be used again in another session. But
you will find it easier to use PediTree if you tidy up the lists as you go.

1   Click on the Choose List button on the speed-bar (or choose List > Choose... from the
main menu) to get the List Dialogue.  The two lists we have created will be the last
two (3 & 4) in this list of lists.  Right-click on list 4 and choose Erase list 4. List 4
will now show its Method as Erased.  Do the same on List 3.
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2  List 2 shows a Method of AncTree.  If
you followed the editing instructions in
the last chapter, then this Ancestor Plan
is out of date; remember, only those
lists with Method = Index stay up to
date when changes are made.  So,
whilst you are in the mood, erase this
list also.  We will re-create it in the
next chapter.

3  Finally, click on the window close button to close the List Dialogue.
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Chapter 5 Tutorial
Printing Trees and Charts
A Trees and Tree Plans
 An important feature of PediTree is its ability to design family trees automatically.  It

can be very difficult to draw a family tree by hand — all the people must fit in some-
where on the paper.  PediTree will decide where to place people on a tree without
any assistance from the user.

 To create a tree in PediTree, two steps must be performed:

1. Create a plan of the tree; this indicates were the people will be placed.  This plan
is a PediTree list, like the index and filtered lists we used in the last chapter.

2. Print the tree, using the plan already created.

 Plans can be for Descendant or Ancestor trees and are identified by letters A, B, ... In
PediTree, it is useful if Plan A is an Ancestor plan from the youngest descendant in
the family; the reason for this will be explained in a moment when we have created
such a plan.

 You can also display and print Ancestor or Descendant Charts, for any person, with-
out first creating a plan.

B  Starting PediTree for this Example
1  You can continue from the previous chapter if you wish.  If you have had a break,

then start PediTree again and open the Royal03 database.  See chapter 3, sections A
and B if you need to remember how to do this.

2  Check that you have only one list: List1 indexed with 154 Person records (150 if you
haven’t followed through chapter 3). If you have more lists, then erase them; the pro-
cedure was given in chapter 4, section F.

C  Creating and Using Plan A
1  In the family display, locate William, Prince Charles’s son, and click to select him.

Now click on the Ancestors Plan button on the speed-bar (or choose List > Ancestors
plan... from the main menu). In the following dialogue, set the number of generations
to 20, either by editing the number or repeatedly clicking the up-arrow next to it.
Then click OK. A new list display will appear titled List2 AncTree A...

Note:  in this list display, the two numbers at the left are the generation-number,
followed by the strip-number. These correspond to the position that the en-
try will occupy on a printed chart. On a top-down tree, the generation is the
vertical position; the strip, the horizontal position.

2  Now double-click William’s father (Prince Charles) in the family display, to bring
him to the centre of this display.  Notice that William and all the other people shown
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in the family display are marked with an asterisk (except Harry, if you have added
him). Every person appearing in Plan A, the ancestors of William, is now marked
with an asterisk in the family display.  You can check this, if you wish, by following
his ancestral lines in the family display.

3  To see this plan in graphical form, right-click on any entry in the List2 window and
choose Tall tree.  After a moment, the Ancestor plan will appear in diagrammatic
form, with William at the far left.  Each small blue rectangle represents a person; if
you depress the left mouse-button with the pointer on such a rectangle, you will see a
display of the text it contains.

 The dark grid overlaying the diagram indicates the page boundaries if this plan were
to be printed. I’m not suggesting that you spend that much paper; there’s a summary
of the total number of pages at the top of the diagram.

4  The tabs at the top of the diagram represent different levels of detail, which we’ll be
exploring shortly.  Click on Back to return to the list.

D  Creating a Descendants Plan
 To create a plan for a conventional descendants tree, you must first decide whose

tree you want.  A descendants tree shows all people descended from a particular per-
son.  In this sections we will print trees for the descendants of the Queen’s father,
George VI.

1  Select George VI by clicking on him,  either in the family display or in a person list.
You may want to close List2 so that you can see List1; just click the close button at
the top-right of List2.

2  Now click on the Descendants Plan button on the speed-bar (or choose List >Descend-
ants plan... from the main menu). In the Choose number of Generations dialogue that
appears, you can leave the number set
at 5 and click the OK button. A new
List3 DescTree B... will appear.

3  Right-click on any list entry and choose
Wide tree. After a moment, the tree will
appear in diagrammatic form, with blue
boxes representing the people and dark
vertical lines marking the page bounda-
ries.   Notice that some of the vertical connections are red; this is Plan A in operation
again, marking the line of descent to Prince William.  As before, holding down the
left mouse-button over a blue box will produce a display of the text, as shown in the
illustration overleaf.

 Some adjustments to the layout are helpful before printing this tree.  First, the text
should be centred in the boxes; secondly, the tree will fit better on landscape paper.
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4  Right-click on the diagram and choose Layout.... In the Layout TREE dialogue, make
sure that Justify in box is set to Centre, Width to 20 and height to 8, then click on OK.

5  Click on the Set Printer button on the speed-bar, set the orientation to landscape and
click OK.

 The blue boxes are now centred on the
vertical lines and the diagram fits onto
two pages.

6  Right-click on the left-hand page of the
diagram and choose View row 1 page 1
to see how it will look when printed.
You will see that the red line-of-de-
scent appears (and will be on the
printed result if you use a colour
printer).

7 Right-click in the middle of the blank
area top left of the tree and choose Authorship rectangle... to display text copied from
your registration details.  You may edit this, if you wish, double-clicking when satis-
fied.  The result will appear in a box at the position originally selected when you
right-clicked; choose View row 1 page 1 again to see it.

8  Right-click again and choose Print all... You will get a printing dialogue, as before, at
which you can click OK to print the tree on two pages.  A reduced-size version is on
the next page.

9  The three tabs Brief, Normal and Detailed provide different amounts of detail for the
tree entries.  We printed the Normal version.  Try selecting the other two in turn and
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inspecting the box containing Prince Charles’s information to see the changes.  You
can also alter the size of the boxes from the Layout TREE dialogue and the font from
the main menu Print > Fonts.... Reducing the Main body font size to 6 (points: this size
isn’t in the drop-down list, but you can type it in the box) fits this tree onto a single
page.

10 Finally, click on the Back tab to return to List3.

E  Tall Tree
 This alternative layout is sometimes a better fit onto the sizes of paper available from

computer printers. We saw it briefly when studying Plan A at the start of this chap-
ter. Let’s now see how our wide tree appears in this form.

1  Again right-click on any entry in List3 and choose Tall tree. If you altered the font
size in the previous section, now reset it to 10 point. Right-click on the diagram,
choose Layout... and set Ancestor Posn. to Left, Justify in box to Left, width to 25. Click
OK; you will see that the tree in this form fits on one page. Right-click again and
choose View ... to browse the page as it will print; print it if you wish.  See the illus-
tration on the next page.

F  Ancestors Tree
 Like the Descendant tree we have been using, you can also produce Ancestor trees.

We will produce one for Prince William, printing it as a wide tree.

1  Select Prince William, either in the family display or in List1.

2  Click on the Ancestors Plan button on the speed-bar (or choose List >Ancestors plan...
from the main menu). Set the number of generations to 4, then click OK.

3  Right-click any entry in the new List4 and choose Wide tree. In the Layout TREE dia-
logue set Justify in box to Centre and set the width to 20. If you set the font-size to 8
points, then this tree will fit on one page.  Feel free to print it, as before, then click
the Back tab. This tree is not illustrated here.
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G Wide Tree with Image
 You can display any available images on a Wide Tree if the size of individual dis-

play boxes is made big enough.  You need at least six blank lines beyond any text.
We will show this using the image of Henry VIII.

1 Find Henry VIII in the list display of List1 and select him with a click. Click the
Descendants Plan button on the speed-bar, then click OK in the ensuing dialogue.

2 Right-click in the resulting DescTree list and choose Wide Tree.  When the diagram
appears, click on the Brief tab (images are only displayed by this form of the Wide
Tree).

3 Right-click in the diagram and choose Layout.  In the Layout TREE dialogue, alter the
height to 15, then click OK.

4 Right-click in the top-left page of the diagram and choose View row 1 page 1.  You
should see the image of Henry VIII below his entry, as shown opposite.

H  Lines of Descent
 You can restrict the coverage of either a Descendant Tree or an Ancestor Tree to just

the relationship between two individuals.  The Ancestor Tree form is known as a
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Line of Descent.  For example, let us
generate the Line of Descent from
Louis of Battenburg P026 to Prince
William.

1  Generate a Descendants Plan from
Louis P026: find Louis in either List1
or the family display. The default 5
generations is sufficient; this produces
List6 DescTree E.

2  Generate an Ancestors Plan from
Prince William P092: find William,
click the Ancestors Plan button; 5 gen-
erations is enough, but now click the
down-arrow in the FamilyDescent box and choose only plan E DescTree by clicking on
it.  Now click OK to produce List7 AncTree Fe (the suffix ‘e’ indicates that it con-
tains selected ancestors).

3  Right-click any entry in this new list and choose Wide Tree to see the result.  This
will print on one landscape page, if you change the height back to 8 in the Layout
TREE dialogue. Click the Back tab to get back to the list display.

 The alternative approach shows the same relationship, but with the addition of sib-
lings at each generation.  We need an Ancestors Plan from William, which we
already have (List2 AncTree Plan A).

4  Generate a Descendants Plan from Louis, as above, but setting only plan A AncTree in
the FamilyDescent box.  This produces List8 DescTree Ga.

5  Generate a Wide Tree, as before.  This will go on one page if the font size is reduced
to 8 points (and height is 8). Click on Back!

6 You now have several list windows.  All except List1 can usefully be closed to tidy
the desktop, by clicking on their close-button.

J Descendants Chart
 As well as family trees, PediTree prints compact charts of descendants.  These do not

require tree plans. You simply select the ancestor, then click the button on the speed-
bar, or choose Print > Descendants chart... from the main menu.  For comparison with
the trees produced above, we will print a four generation chart of the descendants of
George VI.

1 Find George VI (P062) in the family display or a person index (List1). Click on the
Descendants Chart button on the speed-bar (or choose Print > Descendants chart...
from the main menu).
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2 The Choose number of Generations dialogue appears.  Alter the number of genera-
tions to 4, then click OK.

3 An outline of the descendants chart is displayed, with a Detail Box below that oper-
ates in the usual way.   Double-clicking on the open-folder icons will collapse the
branch of the chart below it, as will pressing the - key.  Try double-clicking on the
folder next to Queen Elizabeth II.  To expand a closed folder, double-click on it or
press the + or * keys. A double-click or + key expands that level only; the * key fully
expands that level and any below it.  Right-clicking anywhere on the outline and
choosing expand chart will fully expand the whole chart.

4 You can choose the level of detail to appear in the printed chart by selecting one of
the three tabs: Brief, Normal or Detailed.  Click the Normal tab to see the chart as it
will be printed.  If you wish, right-click and choose Print all... (there’s only one page).

5 Click the close box (top-right of the chart window) to remove the chart window.

K Ancestors Chart
 As for descendants, there is a compact chart of ancestors.  Again, no tree plan is

required; simply select the person whose ancestors are required and press the speed-
button.  As an example, we will print an ancestors chart for Prince William
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1 Select Prince William (P092) in the family display or a list.

2 Click the Ancestors Chart button on the speed-bar (or choose Print > Ancestors chart...
from the main menu).

3 The Choose number of Generations dialogue appears.  This time, alter Indentation  to
6, then click OK. As before, an outline of the ancestors chart appears, with the same
options as described in the previous section. Click the Normal tab (or Brief or
Detailed if you wish).
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4 The chart as it will be printed will appear.  Note that the generations are more deeply
indented than the previous descendants chart.  Print it if you wish, then close the
chart window.

L Delete Unwanted Lists
 We have created six new lists in this chapter.  As before, we should erase these

before finishing, unless you expect to revisit them. The way to do this was given in
chapter 4, section F; this time, Lists 1 & 2 can stay.

 This concludes the tutorial using the Royal03 database. You should now have some
knowledge of the operation of PediTree.  Before diving into entering your own
research results, you may want a bit more practice on entering information from
scratch into an empty database.  Your information may (should?) include information
about sources, including 19th century census returns.  The next chapter continues the
tutorial approach to cover these subjects.
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Chapter 6  Tutorial
Entering your own Family
 Having been introduced to PediTree operations on an existing database, now it is

time to see how you would start entering details from your own researches.  This
chapter assumes that you have worked through the steps in chapters 3–5, or are oth-
erwise familiar with the basic operations of PediTree.  It takes you through the steps
involved in entering the details of a small family, including some source and census
information.

 If you already have information stored in a database under the MSDOS program
Pedigree, then you can use that existing database right away with PediTree.  But to
take full advantage of new facilities, you will need to transfer that information into a
new database made from Elton55.  The way to do this will be explained in section G
of this chapter.

A Create a new empty database
1 Start PediTree, then open database Elton55.ped. Both these operations were described

in chapter 3 sections A and B.  If, however, PediTree is already running with another
database open, then Elton55.ped may not be visible in the Open Database dialogue.
In this case, double-click on the parent folder name (pedigree) to make Elton55.ped
reappear.

2 From the main menu, choose File > New DB.... In the resulting dialogue, enter the
name for the new database, which must
be one not previously used, that is, not
showing in the dialogue.  For your own
database, use an appropriate name (you
are limited to eight characters); for this
tutorial we will use the name Roe. So
type Roe in the blank box at the top of
the dialogue.  The Dbtype should be set
to .ped 1Mb; here you can choose other
database sizes when required. Start
with the 1Mb size, as this will accom-
modate the majority of databases and
you can always convert later when
needed. Finally, click OK to create the
new database.

3 A message “Keep index keys, but slowdown import” appears. Click on Yes. After a
moment, an empty family display will appear.  This is the face of a new empty data-
base.  If you click on the Choose List button on the speed-bar, you will see that five
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indexes are defined, all of them currently empty.  Since an empty list can’t be dis-
played, there is no list display to accompany the family display.

Note:  clicking No in the previous dialogue creates a new empty database with no
indexes defined.  This is the appropriate choice when you are going to im-
port information from another database, but you then have to set up the
indexes yourself.  We’ll look at this option later.

B Enter a Family
1 To make it possible to enter details of a family, you must be in Edit (Update) mode,

so click the View/Edit button in the speed-bar, or choose Edit >Update (Edit) mode
from the main menu.

2 You start by entering a person in the husband (or wife) position in the family display.
Right-click on husband and choose Edit new person to get the edit display. Note that
the sex (M) is filled in for you. Click on the forenames field (opposite the name, not
on it), then type Alan. Press Tab to go to surname, then type Roe.  Use conventional
capitalisation as shown;  PediTree will often convert the surname to all capitals for
display and printing.

3 Click the + next to christening to expand this group. In date, type 17oct1835.  Tab
to place, then type Slindon, Sussex. Tab down or Arrow down to death, then
press Enter to expand this group and type 14 May 1910 in the date field. Tab to
place, then type Brighton, Sussex.

Note:  dates can be entered in a number of different ways and will be stored and
displayed by PediTree in the appropriate standard form. For details, look
up ‘date entry’ in the index of PediTree’s on-line help.

4 Click the + opposite notes to open Text display for notes. Type christening:
source, parish register at West Sussex Record Office, then press
key F9 or click on the - opposite
notes to return to the edit display.
Finally, press key F9 again, or
right-click in the Fields column and
choose Save Ctrl+S or F9 to save the
new entries and close the edit dis-
play.

5 The family display now shows
Alan Roe as the husband. Click on
his name to display the details you
have entered in the Detail Box
below.

6 Right-click on the wife box and
choose Edit new Person.  Enter her



40

Chapter 6  Entering your own Family

details in a similar manner to Alan’s:-

  forenames Susan
  surname Sharp
  birth.date abt1840 PediTree will display this as c.1840
  death.date 27 May 1875
  death.place Brighton, Sussex
  death.notes by accident

 Press F9 to close the edit display and see Susan in the family display.

7 Now we have two entries, we can display the Person index.  Click the Choose List
button on the toolbar to get the List Dialogue. Note that the Person Index size is now
2 and the Marriage index size is 1; entering husband and/or wife automatically cre-
ates a Marriage record.  Click on the Person line to bring up a list display.

8 Click on the title-bar of the family display to make it active, then right-click in the
empty child position 1 and choose Edit new Person. In the resulting edit display, the
surname (Roe) is already filled in for you. Enter the other details:

  sex M
  forenames Bernard
  birth.date 17dec1865
  birth.place Worthing, Sussex

 Again, press F9 to close the edit display.

9 Right-click in the empty child position 2 and again choose Edit new Person. Here are
the details to enter:-

  sex M
  forenames Charles Henry
  birth.date 1869

 Note that you can enter several forenames in the single field.  The birth.place is the
same as the previous entry, namely Worthing, Sussex. Instead of typing this, just
click on the field (or Tab to it) and then press key F3 to repeat the entry from the pre-
vious Person edit. Then you can use F9 again to finish the entry.

10 The third child should go between Bernard and Charles.  You will remember from
chapter 3 that you can insert a child: right-click on Charles and choose Insert Child.
Now right-click on the empty child position between Bernard and Charles, choose
Edit new Person and enter:-

  sex F
  forenames Frances

  birth.date 1867

  birth.place Worthing, Sussex (don’t forget – F3)

 and close the edit display (F9).
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11 Now we’ve got details of a marriage for Bernard to enter.  Double-click on Bernard
so that he moves to the father position in the centre of the family display. Right-click
on the wife, get the edit display for a new Person and enter her: she is Tessa Tilman.
Close the edit display (F9).

12 We’ve found the GRO index entry for this marriage in the Apr-Jun quarter of 1889,
so we can enter a date.  Right-click on the marriage, choose Edit M2 to get the edit
display, press Enter to expand the marriage group and enter Q2 1889 in the date.
Close the edit display (F9).

Add an Adopted Child
 Although our example is rather early for a formal adoption, which was legalised in

1927, we will give Bernard and Tessa an adopted child, Henry. Adopted children are
not entered in the family display, but separately linked from a Marriage record.

13 Bring Bernard and Tessa to the centre of the family display. Right-click on their mar-
riage and choose Edit M2, thus opening an edit display.

14 We need to add a link in the adopted field to a new Person record. Right-click on the
adopted field-name and choose Link to new Person record, then confirm that you wish
to create a new Person. A second edit display opens, in which you can insert the
details of the adopted child: sex M, forenames Henry.

15 Before closing this edit display, there is a link from this person back to the Marriage
record to be added. Right-click on the adoptedBy fieldname and choose Place link to
M2=Bernard Roe and Tessa Tilman. Now close this edit display; the Marriage edit dis-
play will show the part-completed link. Press F9 again to close this display.

16 Click on the marriage in the Family display to fill in the Detail Box, which will show
the newly-added Henry.

Enter a Person on their own
 When it comes, the marriage certificate shows a witness called George Roe.  We

don’t know who he is, but the chances are that he is a relative. We can enter him as a
person on his own; if details of the relationship turn up later, then he can be linked
up appropriately.

17 Click on the title-bar of the list display to make it active.  You will see that it now
shows the six people we have entered. Right-click on any entry and choose Insert
record to get an edit display for a new person, then enter George Roe.  He will appear
in the list display, but not, of course, on the family display.

Note: having added an isolated person, we could make this the start of a new
family.  Simply use the Show Family button on the speed-bar to open a
new family display on this person and then add their relatives.
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Repeated Fields
 You may have records where you have several pieces of similar information to enter.

Two examples are several different residences and a succession of different occupa-
tions.  PediTree provides for this by allowing you to repeat fields in a record (up to
250 times).  You have already seen this in operation when you enter several children,
but the process of repeating the field has been hidden from you. To demonstrate this
more directly, we will give Alan Roe two occupations.

18 Bring up an edit display for Alan Roe, then click the + opposite occupation to expand
the occupation group display. Enter his occupation as in 1871:

  title Draper
  place Worthing

19 We've discovered that he took up this occupation in 1862, and was previously a shop
assistant in Slindon from 1850, at Roe's Drapers (his father's shop, perhaps?). Enter
1862 in the from field.

20 Right-click on the field-name occupation and choose Insert new occupation.  This will
open up a new empty occupation group, in which we can enter his previous title,
place and org(anisation), with 1862 in the To field.

21 Close the edit display in the usual way. Click again on Alan Roe to refresh the Detail
Box, which will now show his two occupations.

22 You can re-arrange two or more repeated fields if they are in the wrong order.  Look
up ‘re-arrange’ in the index of on-line help for an illustrated example.

C Use Indexes
 We have used the Person index (List1) above, but there is also a Marriage index.

1 Click the Choose List button on the speed-bar to get the List dialogue, then click on
the Marriage line to display this index as List2.  You will see the two marriage
records that have been created.  Move this list display (by dragging the title-bar) so
that you can see List1 underneath it.  You should now be able to move between the
two list displays by clicking on a visible part of the inactive window to bring it to the
front.

 We will update Alan Roe’s Person record and then his marriage to Susan, using copy
and paste to repeat place information

2 In List1 (Person records), right-click on Alan and choose Edit P1. Expand the birth
group, then the christening group and tab to the place field, so that it is shown high-
lighted (light text on dark background). Either right-click and choose Copy, or press
keys Ctrl+C.  This will copy the highlighted text to the Windows clipboard.

3 Click on place in the birth group, so that the flashing edit cursor is seen, then either
right-click and choose Paste, or press keys Ctrl+V.  The text from the clipboard will
appear in this place field. Close the edit display in the usual way.
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4 Select List2 display (Marriage records), right-click on Alan Roe & Susan Sharp, then
choose Edit M1 to get a Marriage edit display. Expand the marriage group,  move to
place and paste in the clipboard text (Ctrl+V or right-click > Paste).  Move up to date
(Up-arrow) and enter 17 Jun 1862, then close the Marriage edit display.

5 Make the family display active, then move Alan Roe to the centre (by a double-click
on his name).  Note that the marriage details now appear between Alan and Susan
and the Detail Box now shows both these and the three children, including Bernard’s
marriage.

List Places
 It is possible to prepare a list of all the place entries in your database.  As well as

being a useful check on how consistent your place names are, it can produce a pick-
list of frequently-occurring places to speed up their entry.  We will try this on our
small database.

6 From the main menu, choose List > Places list. A new list display titled Places will
appear.

7 Right-click on any entry and choose Sort list. This will put the list into alphabetic
order.  You will notice that we haven’t been consistent in always adding the county!

8 Right-click again and choose Places picklist. A Save As dialogue will appear, offering
the filename Plac.LST. Click Save.

9 Right-click on a Worthing, Sussex entry and choose Edit, click on the + by birth to
expand the group. Right-click on the place field and choose Pick from list, to get a dis-
play of place-names.  Choose one by a click and it will appear in the chosen field.

10 We don’t want to make this change to the record, so press the Esc key (or click the
close button on the edit display). Confirm that you don't want to save this record
update, by clicking on No. You can now close the Places list display.

D Using Sources
 Sources of information can be entered in PediTree in a number of different ways.

• A general note about a person, such as the note about the christening of Alan Roe.
This is better than nothing, but doesn’t take advantage of the facilities of Peditree.

• A note about a particular event. For the death of Susan Sharp, we entered a note ‘by
accident’. We could have added source information ‘ - see death certificate’. This
encourages entry of source information for each event, but mixes up the extra infor-
mation with details of its source.

• A record for a general type of source.  If you give the date and place of birth and say
that the information comes from a birth certificate, that is a sufficient reference for
most purposes.  Such a Source record can then be referred to in the relevant places in
other records; we say it is linked to these records. In the method to be suggested in
these instructions, such a general source record does not contain a list of the people
to whom it applies.
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• A specific source, like a will, that names several people.  PediTree permits you to
enter the information in one source record, with the text of the document (or a précis)
and a list of the person records involved.  Then a reference to this source record can
be entered in the Person records involved.

• Similarly census records, for which PediTree provides special facilities.

 To illustrate some of these ways, we will enter a couple of general sources and a cen-
sus record for one of our households.

1 To enter the first Source record, choose Edit > Edit record > Source, then click Insert in
the Select Source RIN dialogue. This produces the familiar edit display, but for a
Source record. Here is the information
to enter:-

  type cert.

  text certificate held
  by Geraldine Roe

 (We are making Geraldine the genealo-
gist of the Roe family.) Close the edit
display.

2 Now we have one record, we can display the Source index: click the Choose List
button on the speed-bar, then click on the Source index line.

3 Another source record: although you can use the same method as in 1 above, it is
quicker to right-click in the Source List and choose Insert record. What about

  type family knowledge

  text known by Geraldine Roe

4 Now let’s use one of these sources. In the Source index list display, click on cert. to
select it. Now make the Person list active, right-click on George Roe and choose Edit
P7. Right-click on the sources field-name and choose Place link to S1=^S001 cert. The
field will show S1=^S001 cert. Close the edit display (F9); the Detail Box for
George will show source^S001 cert.

5 In the family display, bring Bernard Roe to the centre, then right-click on his mar-
riage and choose Edit M2.  In the edit display, expand the marriage group, move
down to source and choose Place link...  Close the edit display in the usual way, then
click again on the marriage in the family display to fill the Detail Box.  You will see
the source reference has appeared.
Note: whenever you right-click on a link field, PediTree will offer the appropriate

current selected record for placing; you don’t need to mark it first.

E Census Records
 In PediTree, information from census returns is stored in both Source and Census

records, duly linked together.  This allows unprecedented facilities for sorting and
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analysis, valuable when dealing with a common name and many possible house-
holds.  We will enter details for one household in 1871 at 675 High Street, Worthing,
which has the (fictitious) PRO reference RG10.9999.p99:-

 Name Relation Status Sex Age Occupation Where born
 Alan Roe head married M 35 Draper Slindon
 Frances Roe daughter unmarried F   4  Worthing
 Charles Henry Roe son unmarried M   2  Worthing
 George Roe brother married M 32 Grocer Slindon

 We can see that this corresponds to our first family, less wife and eldest son. It
includes the George of the wedding certificate, so we now know who he is.  We can
deal with this later; first, to enter the census information.  There will be a Source
record for the address and date, then four Census records for the individuals.

1 Add a Source record (right-click in the Source list, choose Insert record) with the
details given above:-

  type census
  date 3 Apr 1871
  refnum RG10.9999.p99
  place 675 High Street, Worthing
  county SSX

Note: if you didn’t go though section D, then you will have to use the method of
paragraph D1 to add this record, then display the Source index as in D2.

2 Right-click on the censuses field-name and choose Link to new Census record, then
confirm that you wish to create a new Census [record]. An Edit display for a new
Census record will open.  It is fairly obvious where most of the information goes, but
here are the entries to be made:

  refnum 001  a three-digit sequence number, increasing
      by 1 for each record: 001; 002....
  forename Alan
  surname Roe
  relationship head
  status m  use m ; u ; wid ; widr
  sex M
  age 35
  occupation Draper
  born Slindon

 The source field will be filled in automatically by PediTree when this Edit display is
closed.

3 Click on the Family display to bring it to the front, then click on Alan Roe to select
him.
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4 Click on the Census Edit display, right click on the field-name individual and choose
Place link to Alan Roe... . If the person shown is wrong, repeat step 3 and click on the
correct person.

5 When satisfied, press F9 to save the new Census record and return to the Source Edit
display. The new censuses link will be present, but the text may be incomplete until
this Edit display is refreshed. PediTree will automatically add a link from Alan’s Per-
son record to his Census record.

6 Right-click on the censuses field-name, and choose Append censuses 2.  Right-click
on the new censuses field-name, choose Link to new Census record, confirm that you
wish to create a new record and add the next individual, as listed on the previous
page. Don’t forget to use key F3 (ditto) for the surname at least. Again visit the Fam-
ily display to select the appropriate person, then place the link in the individual field.
Press F9 to close the Census edit display. Repeat steps 2–5 for the other two individ-
uals, appending a new censuses field after the previous entry each time. George isn’t
yet in the Family display, so leave his individual field until he is (see paragraph 12
below).

7 Finally, close the Source Edit display by pressing F9. If you again select any one of
the individuals of the previous paragraph, you will see the census details appear in
the Detail Box.

Add a Sibling
 The census return has told us of George’s relationship to Alan, so we need to add

George into the family (as Alan’s brother).  We can only do this with Alan in the
child position, so first we must give him a father (or mother).  But we have no fore-
name – no problem in PediTree, as we can assume a surname for his father.

8 Make sure Alan Roe is in the father position (at the centre of the family display),
then right-click on his father (top right) and choose Edit new Person. The edit display
appears with sex=M and surname=Roe; press key F9 to close it.  The family display
now has father ROE and marriage, with Alan as a child.

9 Right-click on George Roe in the list display of List1 and choose Mark P8.  Make the
family display active again, right-click in the vacant child position below Alan,
choose Place P8=George Roe... and confirm.  George and Alan are now brothers.

10 We can infer George’s birth-date from his age in the census (32): about 1839. Edit
his record and add this birth-date, using the form c.1839.

11 As a check, we can set PediTree to display ages at the date of the 1871 census.  From
the main menu choose Options > Dates..., then drop down the list at the top (by click-
ing the down-arrow at its right) and choose 03 Apr 1871 from the resulting list.  Click
OK to close the dialogue.  Now click on any entry in List1 list display and their age
is shown after their name; except Tessa Tilman or Alan’s father, for whom we have
no birth-date.
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12 Now we can add a link to George from his Census record. First click on his name in
the family display to select him.

13 Double-click the census entry in the Source list to bring up the Edit display. Right-
click on the censuses 4 field-name and choose Edit linked record, to display George’s
Census record. Right click on the field-name Individual and choose Place link to
George Roe.. . Press F9 to close the Edit display.  Keep the Source Edit display open.

Edit Panels
 When entering the census information, you may wish to see only those fields in the

Source record that are applicable. You can do this with an Edit panel.

14 Right-click on any field and choose Edit Panel > Modify Panel to get the Change Edit
Panels for Source dialogue. Click the Add Panel button, then type Census in the
blank entry in the Edit Panels list above. In the central list, select each of the follow-
ing fields in turn and click on the► button, which will transfer the selected field to
the right-hand list:

  type date refnum

  place censuses

 Finally, the dialogue should look like this illustration.

15 Click the OK button to create the new
edit panel and return to the edit display.
Only the needed fields now show.
Note that the name of the edit panel in
effect appears in the title-bar thus: [cen-
sus].

16 To return to seeing all fields, right-click
in the fields column and choose Edit
panel > <all fields>. Finally, press F9 to
close the Source Edit display.

F Database Checks
 We’ve added some information to our

new database and then made some
changes to it.  Working on real infor-
mation, you might easily gather several hundred records of various types over some
years of research.  It is wise from time to time to make any possible checks that all
the information is intact and readable.  Modern computers and programs are fairly
reliable, in spite of increasing complexity ‘under the hood’, but things do go wrong
occasionally.

 PediTree includes a facility to check its database.  This check is mostly concerned to
detect badly corrupted records and any missing links between husbands, wives, their
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marriages and their children.  It also checks links between Source, Census and Per-
son records and checks the order of entries in indexes.  If it finds index-entries in the
wrong order, it asks if it may correct the index: answer yes to make sure that you can
find all entries in future. If check database is used in Edit (Update) mode, it can
repair most missing links.

 The other useful check is to cause PediTree to read through all the records in the
database, to ensure that they are, in fact, readable!  The way to do this is to export a
GEDCOM file from the database.  We will now make both these checks on our data-
base.

1 From the main menu, choose File > check DB. You should see a message DB integrity
good after a very short delay; click OK to remove it.  To see more information,
choose Help > diagnostics, which will display a message window; double-click on it
to remove.

2 From the main menu, choose File > Save As GEDCOM > GEDCOM 4 Pedigree. After a
short delay, a Save As dialogue will appear, with the File name Roe. Click on Save,
then click No when asked to ‘Preserve RINs by making empty records for dele-
tions?’. If all is well, after a short delay a confirmation message will appear; click
OK to remove it.

Note:  GEDCOM files provide a means of transferring information between data-
bases, be they Pedigree Software databases or those of other family histo-
ry programs.  For more information on GEDCOM files, see the book
GEDCOM Data Transfer (Moving your Family Tree) by David Hawgood
(available from Family Tree Magazine, 61 Great Whyte, Ramsey, Hunting-
don, PE26 1HJ, UK, or elsewhere).

Note:  the alternative choice of GEDCOM 5.5 is for transferring information from
PediTree databases to other family history programs that use this stand-
ard. GEDCOM 5.5 cannot be read directly by PediTree; GEDCOM 4 Pedi-
gree isn’t suitable for other programs.

G New Database from GEDCOM File
 We have assumed so far that you are creating your database by keying in the infor-

mation from scratch.  The other common situation is where you have an existing
database and wish to move to PediTree.  In this latter case, a GEDCOM file exported
from the existing database is the means of moving your information.  As we have
just created such a file, we will go through the steps of importing it into another new
database.

Note:  if you are coming from a previous Pedigree Software database based on
the Families or Census designs, then this process is straightforward.  Com-
ing from any other Family History program is not as easy.  See GEDCOM
Import in PediTree online help for further details.
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1 With your Roe database still open, make a new database called Roe2. The steps are
as in section A2 of this chapter. When the message “Keep index keys, but slowdown
import” appears, click on No. After a moment, an empty family display will appear.

Note:  this new database has no indexes, which is the recommended choice
when it is planned to import a GEDCOM file.  We will create the indexes
after the import.

2 Click the View / Edit button on the speed-bar to switch to Edit (Update) mode.

3 From the main menu, choose File > Import > GEDCOM, when an Open dialogue will
appear. You should see your GEDCOM file Roe.ged; click on it to choose it, then
click Open. A GEDCOM Import display will appear, with a summary of the records
to be imported. Click the Add button.

4 The GEDCOM Import display will now have added information.  Click Finish to
complete the import.

5 You have no indexes, so a List Dialogue appears to allow you to create them. Click
on Person, to get a display of the index keys on the left, Person record fields on the
right.

6 Click on surname for Key 1; click forenames for Key 2; click birth, then date for Key
3; click OK to create the index.

7 In the list display that appears, select Alan Roe, then click the Show Family button in
the speed-bar to bring up the family display.  You should find that all the information
you have added to the original Roe database is now present in this one (Roe2).

8 There are four other standard indexes to create. For each, use List > Index create to get
the List Dialogue, then make choices as set out below (we’ve done the first line
already). The dot-separated entries, like birth.date, mean that the choice is made in
two steps.

Key 1 Key 2 Key 3
 1 Person surname forenames birth.date
 2 Marriage husband.surname wife.forenames
 3 Source date type title
 4 Census surname forenames source.date
 5 Census source.RIN refnum

9 You now have a new database set up, loaded with existing information and ready to
use.

H Back-up and Restore
 Now is the time to test your routines for making back-up copies!  There’s nothing to

lose – yet, so why not make a back-up copy of the Roe database, delete it entirely,
then restore it from the back-up copy?
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 Not knowing what back-up method you intend to use, I can’t give detailed instruc-
tions for this. See the general remarks about back-up in chapter 2.  The outline is as
follows:

1 Leave PediTree. This is important: if PediTree still has your database open, the
back-up may be incomplete or inconsistent.

2 Make your back-up copy of the Roe.ped database (the whole folder
c:\Pedigree\Roe.ped).

3 Delete the folder Roe.ped.  Using Windows Explorer, select that folder, then press
the Delete key.

4 Recover the folder Roe.ped from your back-up copy. If that was a CD-ROM, you
will need to remove the read-only attribute from all the files in the folder: see chapter
2 for details.

5 Start PediTree, open database Roe.ped and verify that your data is present.

 If this process works, then you will have some confidence that your regular back-up
copies will be of some use when needed!

J Other Matters
 We have touched on the most common actions needed to enter your family informa-

tion, but you will probably encounter situations not covered by what you have
learned so far.  Use the on-line help or right-click on field-names in the edit display
and choose help on ... to get additional information when needed. One situation that
may arise is  unmarried liaisons with children. Help on this can be found in Help >
Contents > Contents >Database Record Types > Marriage Record.

Unmarried Liaisons
 Any partnership with natural offspring is entered as a marriage in PediTree. To dis-

tinguish formal marriages from other liaisons, add a note describing the relationship
in the marriage.notes field and enclose it in parentheses, for example ‘(common-law
marriage)’ or ‘(one-night stand)’.  This note will then appear on some printed output
and any ‘m.’ will be replaced by ‘=’.
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Chapter 7  Using your Database
 Once you have entered your information into a PediTree database, what can you do

with it? This brief chapter can but hint at some of the possibilities and indicate rele-
vant entries in the PediTree on-line help.

Printing
 In chapters 4 & 5, we have looked at some of the Reports, Tables, Trees and other

charts that you can print.  The addition of Source and Census records adds to the
range of possible Reports and Tables.  If you follow the techniques of chapters 4 &
5, you can explore these possibilities, not only for the Person and Marriage records
that were shown there, but also for the Source and Census records. Printed output is
useful both as an aid to further research, also to pass to others who are interested in
your information.

Filtering and Sorting
 A powerful technique to aid your research is that of producing selective lists by fil-

tering, as explored briefly in chapter 4 sections C and D. See Help > Contents > Index
> filter examples for more information. You can also create other indexes that are in a
different order from the standard ones, as created in chapter 6 section G. Start from
List > index create... to roll your own.

Find Text
 PediTree can search for text anywhere in your database, unlike a filter that works on

specified fields.  So if you know that an elusive particular name or phrase is some-
where in there, this may help.  See Help > Contents > Index > find text for details.

Replace Text
 You can find and replace text with PediTree; useful for correcting systematic mis-

takes in your records. Like any find and replace operation, it risks making unex-
pected changes, so it is essential to make a back-up copy of your database before
using it. See Help > Contents > Index > replace text for more information.

Exporting Information
 You can export information in forms that can be imported by other programs, such as

Word Processors, Spread-sheets, even other Family History programs.  We’ve seen
how to export text in chapter 4 section E; a similar technique will provide CSV text
suitable for import to a spread-sheet or database. In chapter 6 section F, we exported
a GEDCOM file (as a check on the database); such a file can be imported into other
family history programs.  This GEDCOM file contained all the information in our
database; you can also produce such a file containing part of the database, as defined
by a particular list.  See Help > Contents > Index > GEDCOM List Export for details.
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Index
add

child, 18, 40
marriage, 19
occupation, 42
person, 41
sibling, 46
spouse, 19

ancestor
chart, 29, 35
tree plan, 29

ancestors
plan create, 29

attributes, 4
Authorship rectangle, 31
back-up, 9

test of, 50
browse family, 14
census records, 45
changed, 18
check database, 47
child

add, 40
detach, 21
insert, 18, 40
reposition, 19

clipboard, 42
copy (Ctrl+C), 42
Ctrl+C (copy), 42
Ctrl+V (paste), 42
database, 4

capacity, 9
check, 47
create new, 38
designs, 4
new, 48
open, 12
version, 6

date entry, 39
delete

list, 27
marriage, 22
person, 21

descendant
chart, 29, 34
tree plan, 29

descendants
plan create, 30

detach
child, 21
spouse, 21

Detail Box, 14
detail grid

occupation, 42
edit

display, 17
marriage, 18
new person, 18, 39
person, 17

Edit (Update) mode, 17
Elton55 database, 11
exit from PediTree, 12
export

GEDCOM, 48
text, 27

F3 (ditto), 40
F9 (save), 39
family

browse, 14
display, 12
enter, 39
starting new, 41

fields, 4
filter list, 25
find in index, 16
fonts, setting, 12
GEDCOM, 4

export, 48
import, 49
save as, 48
version, 48

GZip (program), 8
help, getting, 6
hot links, 15
images

hot links, 16
import

GEDCOM, 49
index, 16

create, 49
keep keys, 38
standard, 49
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using, 42
insert

child, 18, 40
marriage, 19

line of descent, 34
list

choose, 42
delete, 27, 37
display, 14
places, 43

mark and place, 20, 46
marriage

add, 19
delete, 22
edit, 18
insert, 19
select, 15

mouse use, 5
multiple fields, 42
multiple marriages, 17
new database, 38, 48
notes, entry of, 39
options dialogue, 46
paste (Ctrl+V), 42
Ped-FHS (program), 8
Pedigree

existing databases, 38
program, 4
Users Group, 6
utilities, 7

Pedigree Software
contacting, 6

PediTree
installing, 7
serial number, 11
starting, 11
stopping, 12
version, 6

person
delete, 21
select, 15

photographs, 4
places list, 43
places picklist, 43
plan, diagram, 30
print

image, 25
Report, 23

set orientation, 24
Table, 26

PVSort (program), 8
read-only attribute, 8
record, 4
Record Identity Numbers, 13
relationship calculator, 20
repeated fields, 42
Report, 23

design, 25
RIN, See: Record Identity Number
Royal03 database, 11

restoring, 22
save edits (F9), 39
setting fonts, 12
sound recordings, 4
sources

general type, 43
place link, 44
using, 43

speed-bar buttons, 13
spouse

add, 19
detach, 21

starting PediTree, 11
surname capitalisation, 39
swiping, 15
Table export, 27
tree

ancestors, 32
layout dialogue, 31
plan, 29
viewing, 31
with image, 33

Windows
using, 5
version 3.1, 7

WinZip (program), 10
zoom Detail Box, 16
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